amobbs.com 阿莫电子论坛

 找回密码
 注册
搜索
bottom↓
回复: 19

LM358部分不工作?

[复制链接]
(348576639)
发表于 2009-5-20 11:44:56 | 显示全部楼层 |阅读模式
今天通过TIM3输出了2个PWM波,通过示波器观察可以通过按键调节PWM波的占空比,但是万用表测量LM358的输出,电压不变,何解?
(348573130)
发表于 2009-5-20 12:43:25 | 显示全部楼层
抱歉我的还未焊。

PWN端口置0(电压为0)时 运放输出电压多少?
PWN端口置1(电压为5V)时运放输出电压多少?
(348570848)
 楼主| 发表于 2009-5-20 13:21:27 | 显示全部楼层

(原文件名:pwm.JPG)

图中调PWM占空比时,LM358的3号脚电压变化。占空比每增加1%,电压增加约0.05V,(FLUKE 17B测量)
PWM频率240K, 70%占空比,FLUKE 17B测量读数:3.46(1/2)V,电源脚电源分别为4.98V、-5.01V
(348569546)
发表于 2009-5-20 13:43:09 | 显示全部楼层
抱歉,线路图错了,没校对出来。

请把 U3A-2 与地连接割断。用10K电阻与U3A-1连接起来。
同样 U3B-6 与地连接割断。用10K电阻与U3B-7连接起来。
(348569385)
 楼主| 发表于 2009-5-20 13:45:50 | 显示全部楼层
上面的图看上去有原理上的错误。

我用ORCAD仿真的结果与实际测量结果基本一致。3号脚电压随占空比变化而变化,但输出脚电压恒定不变。
仿真软件仿真输出电压:4.3V,
实际测量结果是3.69V
(348569291)
 楼主| 发表于 2009-5-20 13:47:24 | 显示全部楼层
是的,我竟然没注意到图中少了一个负反馈。
(348569117)
发表于 2009-5-20 13:50:18 | 显示全部楼层
用99SE,没办法编辑MY_AVR出的图。
帖一个自用的图出来参考。

(原文件名:lpf2.jpg)
(348567743)
 楼主| 发表于 2009-5-20 14:13:12 | 显示全部楼层
OK,改好了,但输出电压不能高于3.7V,应该是由运放的输出范围所限。
(348566078)
发表于 2009-5-20 14:40:57 | 显示全部楼层
如果需要高于3.7V,换用LMV358,或者运放供电接电池正。
(348562841)
发表于 2009-5-20 15:34:54 | 显示全部楼层
我的板子都还没有焊

ifree64 有没有测试其他部分的硬件基本功能??能正常工作吗?
(348562367)
 楼主| 发表于 2009-5-20 15:42:48 | 显示全部楼层
按键、LCD、电源部分没有问题,LM358有上面说的问题,其他部分还没有测试。
(348505430)
发表于 2009-5-21 07:31:45 | 显示全部楼层
TL431基准电压电路图是错的。
照电路图和pcb,是得不到3.3v电压的,而是接近于5v
应该将R3和R2交换一下才行。
头像被屏蔽
(348497548)
发表于 2009-5-21 09:43:07 | 显示全部楼层
提示: 作者被禁止或删除 内容自动屏蔽
(348495542)
 楼主| 发表于 2009-5-21 10:16:33 | 显示全部楼层
240K, 是24M的100分频
(348483995)
发表于 2009-5-21 13:29:00 | 显示全部楼层
TL431基准问题。是把取样电阻位置搞反了,下面两只电阻和上面的电阻换位置就OK。
感觉改成 上面用3.3K 下面10K+330R可能方便点。
(348473057)
 楼主| 发表于 2009-5-21 16:31:18 | 显示全部楼层
TL431已经将R2、R3交换,万用表测电压3.23V,
但示波器输出测得有幅度0.5V,周期20us的锯齿纹波,这怎么回事?
(348472549)
 楼主| 发表于 2009-5-21 16:39:46 | 显示全部楼层

(原文件名:sj.JPG)

图中衰减怎么测得是50倍衰减。示波器用x10测的。
(348471290)
发表于 2009-5-21 17:00:45 | 显示全部楼层
TL431已经将R2、R3交换,万用表测电压3.23V,
但示波器输出测得有幅度0.5V,周期20us的锯齿纹波,这怎么回事?
----------------------------------------------------------------
1、可能是负压 MC34063 产生的干扰信号。注意示波器的取地点。
   有条件尝试用电池供负电压。不用MC34063。
2、也可能反馈电阻太大了,试用14楼的电阻值。
(348471034)
发表于 2009-5-21 17:05:01 | 显示全部楼层
得开个集中的补救贴了
(261794111)
发表于 2012-2-18 22:00:24 | 显示全部楼层
模拟电路,头疼
回帖提示: 尽量不要使用Mark、顶等没有意义的回复。不得大量使用大字体和彩色字。在按“提交”前,请自问一下:我这样表达会给举报吗,会给自己惹麻烦吗?
您需要登录后才可以回帖 登录 | 注册

本版积分规则

手机版|Archiver|amobbs.com 阿莫电子论坛 ( 公安交互式论坛备案:44190002001997 粤ICP备09047143号-1 )

GMT+8, 2020-6-5 22:35

© Since 2004 www.amobbs.com, 原www.ourdev.cn, 原www.ouravr.com

快速回复 返回顶部 返回列表