搜索
bottom↓
回复: 44

超声波一体化探头调试中检测不到回波。。。求做过超声波的朋友指点

[复制链接]

出0入0汤圆

发表于 2011-12-6 04:32:13 | 显示全部楼层 |阅读模式
用ATmega8的CTC模式40KHZ方波+升压中周发射+cx20106接收,中间本来用CD4052控制,但是调试的时候没有回波,所以就去掉了。发射8个方波信号后等待1ms后检测回波,接收使用CX20106已经调试正常,可以触发ICP中断,程序连续测量三次求平均值,但是数字还是乱闪,根本没有接收到回波,应该是余震或者是cx20106太敏感受到其他干扰。

其中我有几个问题弄不明白,还望大家指点:
1.cx20106的反馈电阻,我查了好多图纸,有的说是4.7,也有说是10K都不算大的。我自己用电位器调整,在1脚(信号输入端)悬空的情况下,保证7脚(输出端)没有低电平输出。但是这样实验下来。电阻竟然需要200K才能保证cx20106稳定下来,不乱触发。但是这样反馈电阻这么大,超声波回波的小信号应该也不能被放大了吧?
2.因为手头比较简陋,没有好的示波器,只有一台老爷机,也不知道准不准了。测得MEGA8(外接8MHZ晶体)的TC2 CTC模式无分频时,OCR2=0X63时的波形为80KHZ还多,虽然我还是比较相信公式计算应该是准确的,但是探头一直发出哒哒的声音,这是正常的吗?。又测了接收到CX20106的输入端的波形如图,波形里有两个我画圈的位置出现两个幅值的波动,这是什么情况引起的?
3.接收的回波信号幅度我看其他人的资料说应该是mV级别的。但是我怎么放大波形的幅度还是找不到那种能看上去像回波的位置。请大家帮帮忙。给我点思路,下面该怎么调节才能成功。。


接收信号 (原文件名:QQ截图20111206040540.jpg)

出0入0汤圆

发表于 2011-12-6 08:37:52 | 显示全部楼层
哒哒的声音是正常的,请问超声波发送的时间间隔是多少?

出0入0汤圆

 楼主| 发表于 2011-12-6 09:00:21 | 显示全部楼层
回复【1楼】newselect 熊宝宝
-----------------------------------------------------------------------

是这样的,每次发送8个脉冲,然后延时1.2ms等待余震结束,结束后就开启ICP外部事件捕捉中断,等待中断触发,中断触发后进行测距运算,接着就是第二次发送8个脉冲,这样循环3次,然后求出平均值,送去显示,算是一次测距完成。现在波形上显示的就是三次测距的接收回来的波形,示波器我觉得不准,不过当时测量时应该是0.5ms/div左右吧。信号幅度大概应该是0.2V/div


修改原因:1.2ms的延迟时间误写成了1.2us。

出0入0汤圆

发表于 2011-12-6 09:57:29 | 显示全部楼层
应该是延迟时间太短啦~探头余震,那可是相当强烈呀

出0入0汤圆

发表于 2011-12-6 10:06:05 | 显示全部楼层
回复【2楼】gaoguanyixh
回复【1楼】newselect 熊宝宝
-----------------------------------------------------------------------
是这样的,每次发送8个脉冲,然后延时1.2us等待余震结束,结束后就开启icp外部事件捕捉中断,等待中断触发,中断触发后进行测距运算,接着就是第二次发送8个脉冲,这样循环3次,然后求出平均值,送去显示,算是一次测距完成。现在波形上显示的就是三次测距的接收回来的波形,示波器我觉得不准,不过当时测量时应该是0.5ms/div左右吧。信号幅度大概应该是0.2v/div

-----------------------------------------------------------------------

40KHZ 延时1.2us ?你太小看余震了。如果你真是做到胃盲区只有1.2us,那么恭喜你,估计你是世界第一了。

我做200KHZ的时候 盲区还有60mm呢.根据探头盲区再确定下盲区时间把。

出0入0汤圆

发表于 2011-12-6 10:12:53 | 显示全部楼层
回复【2楼】gaoguanyixh  
-----------------------------------------------------------------------
超声波速度340M/S;
传播时间 0.5ms*4 = 2ms,"当时测量时应该是0.5ms/div左右吧"
一来一回的传输距离为:0.002*340/2=0.34M
保守点的话0.3M以内距离是无效的
所以,建议把发送间隔啦长点,有个30ms就好,0.03*340/2=5.1米,留有余量

出0入0汤圆

 楼主| 发表于 2011-12-6 15:17:30 | 显示全部楼层
回复【3楼】lichen867
-----------------------------------------------------------------------

回复【4楼】wenwenba
-----------------------------------------------------------------------

回复【5楼】newselect 熊宝宝
-----------------------------------------------------------------------

是我笔误了。因为探头是问网上的商家买的。后来问他要了技术资料(附图),提供给我的数据是最大余震时间是1.2ms,所以我程序写的是1.2ms延时。不是1.2us。呵呵。抱歉,应该不是延迟的事情。我自己把延迟设置到10ms,但是同样也是看不到回波,智能看到发射波形和余震之后一条平直的斜线。

(原文件名:超声波探头.jpg)

出0入0汤圆

 楼主| 发表于 2011-12-6 15:24:44 | 显示全部楼层
回复【5楼】newselect 熊宝宝
-----------------------------------------------------------------------

再次感谢熊宝宝,头像和你人一样可爱,我试试看,加大等待余震延迟时间看看cx20106能不能捕捉到,反正我示波器貌似捕捉不到,老式的SR8示波器,也没有STOP功能。。扫描速度设置到0.2ms/div,屏幕一直在闪,触发同步以后也是扫描速度很低,示波器又不是长余辉的。看来看去就要被催眠了。。

出0入0汤圆

 楼主| 发表于 2011-12-6 15:31:51 | 显示全部楼层
回复【3楼】lichen867
-----------------------------------------------------------------------

延迟应该不算短了吧?我波形图上面是接受端的波形,一体化探头接收端过来串联一个10K电阻,一个0.1uF电容,然后对地并联两个二极管消除余震的大信号,最后接到CX20106第一脚,波形就是CX20106第一脚侧得的。如果我分析正确的话,我觉得两次发送中间的那段波形已经很平缓了吧?应该是已经过了余震范围的?

出0入0汤圆

 楼主| 发表于 2011-12-6 15:40:29 | 显示全部楼层
回复【4楼】wenwenba
-----------------------------------------------------------------------

多谢WENENBA朋友的提醒。呵呵。时间是1.2ms。笔误了。我已经改过来了。主要是收不到回波。有没有什么好的方法能判断我为什么没有回波吗。或者说什么问题会导致没有回波?
我觉得我的发射波形有点畸变,方波驱动N-MOS和中周组成的他激震荡,以前听说中周变压器次级需要阻抗匹配,初级需要并联电容和前面的震荡电路构成谐振选频,不知道是不是这样。我买的就是普通淘宝上1.2元一个的超声波变压器,没有自带的电容,初级42T,次级420T。10:1的变比,我拆开一个来看,里面就是一个小的工型铁氧体磁芯骨架上乱绕了初次级,在没有其他东西了。具体电路是不是谐振。次级是不是匹配我能力有限,搞不清楚,但是中周输出端的波形测得是个畸变正弦波,又类似三角波,上升时间的中点处波形下陷,但是整个周期还能和单片机输出的周期基本吻合。

出0入0汤圆

 楼主| 发表于 2011-12-6 15:54:25 | 显示全部楼层
这是我的探头驱动电路,以前看资料都是用的8050的三极管驱动中周,我试了很多次,贴片封装mega8的OC2输出40KHZ方波驱动8050基极,一连通到基极,幅值就从4V左右调到零点几伏,三极管导通的时候不能进入深度饱和,两下就烧坏了,所以我觉得应该是单片机端口的拉电流太小,不足以提供足够的8050基极电流使他在高电平时可靠饱和,所以选择了3.3V驱动的N-MOS。型号为FDN-335-NL。我觉得效果还算满意。毕竟是电压驱动,栅极不需要电流。

(原文件名:QQ截图20111206154821.jpg)

出0入0汤圆

发表于 2011-12-6 16:27:13 | 显示全部楼层
该不会直接就测A_Receive端信号吧?没有信号放大?

出0入0汤圆

 楼主| 发表于 2011-12-6 16:36:37 | 显示全部楼层
是啊。就是A_receive测得的波形,用的示波器0.2V/div档位。接收用的CX20106红外/超声波40KHZ的芯片,这个芯片应该是包含了小信号放大,波形整形,施密特触发器这些部分了。

(原文件名:QQ截图20111206163458.jpg)

出0入0汤圆

 楼主| 发表于 2011-12-6 20:36:40 | 显示全部楼层
还是接收不到信号。。大家帮帮忙吧。

出0入0汤圆

 楼主| 发表于 2011-12-7 04:21:37 | 显示全部楼层
实在郁闷了。求人不如求己,连夜又焊了一块NE5532的板子,感觉CX20106太难把握放大增益,又测不到回波信号。放大之后的信号经过片内处理直接就变成下降沿,不直观。参考其他朋友的雷达电路。焊了5532两级放大+施密特触发器。感觉还不错。但是仍然没看到想要的回波信号。。苍天啊。。大地啊。。难道我买的这个一体化探头4个都是哑弹啊?为啥不接受回波呢。。真的想不出来原因了。。下面两张图是又测得的信号。一张是发射端口的发射信号(幅度大概100VP-P)和接受端5532第一级放大之后的波形同步以后。另一张是5532第一级放大后的波形和施密特触发器输出给ICP中断的信号。有没有做过一体化探头超声波的朋友。指点指点吧。实在很头大,做了快一个月了。。。

(原文件名:QQ截图20111207040956.jpg)


(原文件名:QQ截图20111207041014.jpg)

出0入42汤圆

发表于 2011-12-7 08:43:10 | 显示全部楼层
a点伤不起啊,幅度太小了。貌似你用的防水换能器?这个的接收信号幅度很小的,至少放大10倍后测量。如果不是防水的,max232就够驱动了

出0入0汤圆

 楼主| 发表于 2011-12-7 10:48:23 | 显示全部楼层
回复【15楼】albert_w
-----------------------------------------------------------------------

是啊。防水型探头,就是倒车雷达用的那种探头。开始我还以为就是和普通分体探头一样的。用的74hc04驱动的。结果惨了。板子都做出来了。发现峰峰值不够。又问买探头的卖家要的技术资料。傻眼了。180Vp-p。又去买的超声波用中周,勉强够100多伏的峰峰值驱动电压。但是接收电路又不行。如果是回波信号很小的话,那总有1mV吧?还是零点几mV级别的?为啥示波器测不到呢。郁闷。而且cx20106或者5532.轻轻松松也都有100dB以上的增益了吧。如果这样不行的话。还有没有别的方法或者电路能参考一下。先谢谢您了。

出0入0汤圆

发表于 2011-12-7 13:09:12 | 显示全部楼层
MARK

出0入42汤圆

发表于 2011-12-7 13:21:11 | 显示全部楼层
回复【16楼】gaoguanyixh  
回复【15楼】albert_w
-----------------------------------------------------------------------

是啊。防水型探头,就是倒车雷达用的那种探头。开始我还以为就是和普通分体探头一样的。用的74hc04驱动的。结果惨了。板子都做出来了。发现峰峰值不够。又问买探头的卖家要的技术资料。傻眼了。180vp-p。又去买的超声波用中周,勉强够100多伏的峰峰值驱动电压。但是接收电路又不行。如果是回波信号很小的话,那总有1mv吧?还是零点几mv级别的?为啥示波器测不到呢。郁闷。而且cx20106或者5532.轻轻松松也都有100db以上的增益了吧。如果这样不行的话。还有没有别的方法或者电路能参考一下。先谢谢您了。
-----------------------------------------------------------------------
懷疑100db這個說法。
檢查下5532的電路倍數是否正確,d1的用途是?
抱歉沒有參考電路。不妨就用運放直接搭電路。100v的驅動勉強夠了,長距離需要聲聚焦的東西。測試建議反射物垂直且一米左右,先估算好時間,更容易找到波形

出0入0汤圆

 楼主| 发表于 2011-12-7 19:02:53 | 显示全部楼层
回复【18楼】albert_w
-----------------------------------------------------------------------

我查了一下,CX20106的增益资料上说是80dB。确实没有100那么高。5532运放的话。两级OP都是反向放大,每级增益100dB。应该更优越吧?可以这么理解吗?
刚才刚睡醒,起来又测了下输入信号。这次是没有接探头的情况下测得。A通道:NE5532第一级放大之后的信号,B通道:最终施密特触发器输出的信号。用示波器做了A+B输出。这次注意到没有接探头应该是没有反射的超声波信号的吧?但是反而有个小信号被放大了(图中红色框内)。而且最终成功的触发了施密特触发器,说明到达了阀值电压。而且这个信号在一直触发着INT0中断。这个信号是怎么来的呢?没有接探头也不会有余震吧?更不会有反射信号吧。。奇怪了。。郁闷中。。

(原文件名:QQ截图20111207184556.jpg)

出0入0汤圆

 楼主| 发表于 2011-12-7 19:07:06 | 显示全部楼层
如果发射电路停止工作。只是接通接收电路。那么没有噪声,很平静。也没有中断被触发。这是怎么回事啊。。
另回复【18楼】albert_w
-----------------------------------------------------------------------

D1和输出隔离电容器后面的两个二极管是一个作用。因为开始没有后面两个。所以就只有D1。后来截图的时候又按照现在用的电路画上去了两个二极管。所以D1已经没有用处了。

出0入42汤圆

发表于 2011-12-8 01:20:05 | 显示全部楼层
实话说楼上的楼上图没看懂。5532每级100db,啥概念,100000倍,你开环么?12M的增益带宽积,顶天也就300倍。反馈电阻怎么取的?
实际来说两级各30倍,应该非常明显能看到回波了。不行就买瓶,不是罐,可乐,喝了把上半截剪下来,有喇叭口就可以了,不需要太长,套在换能器上,保持同轴。这个反射器还可以。

出0入0汤圆

 楼主| 发表于 2011-12-8 01:46:16 | 显示全部楼层
回复【21楼】albert_w
-----------------------------------------------------------------------

哎。自己再看看吧。电路学的一塌糊涂,很感谢albert_w 现在电路还有点别的问题,发射电路的震荡干扰太严重了。场效应管很灵敏,通电就触发INT0。不给40KHZ信号。用手摸摸栅极都能触发中断。我现在用的这个电路是普通的反向放大。增益确实没有很高。第二级的信号强度已经有1V以上了,第二级放大1V/V的话。按照增益带宽积=12m的话。确实不能有很大增益了。不过在坛子里找到一个图纸。看这个电路很神奇啊。。标称10000倍。。能做到吗。。

(原文件名:ourdev_422963.jpg)

出0入0汤圆

发表于 2011-12-8 03:38:50 | 显示全部楼层
学习

出0入42汤圆

发表于 2011-12-8 14:17:07 | 显示全部楼层
是不是搞错了,平时int不开的,等到发送了tx,并且过了余震阶段再打开即可。当然tx了就要开定时器。
10000倍才80db嘛,虽然感觉太大了。1000倍这个数量级足够吧。100倍每一级应该能做到,但是是否稳定就不好说了。

出0入0汤圆

 楼主| 发表于 2011-12-8 16:48:11 | 显示全部楼层
回复【24楼】albert_w
-----------------------------------------------------------------------
郁闷了。程序应该问题不大。我用定时器1的CTC模式做的40KHZ波形发生,发送4个脉冲。然后延时1000us,启动INT0的中断使能,但是每次都是一开中断就被触发了。查了半天原因。觉得应该是振荡器在停止40KHZ波形发射之后还在震荡?真郁闷了。

出0入42汤圆

发表于 2011-12-8 17:10:50 | 显示全部楼层
可以把比较器的参考电压给高些. 半电压是有风吹草动就触发,可以偏离一些1/2 vcc. 这个偏离就是阈值了.

出0入0汤圆

 楼主| 发表于 2011-12-8 22:44:47 | 显示全部楼层
爽歪歪了。终于调出回波了。。真不容易,2天3夜突击奋战。在此真的很感谢albert_w朋友给我很多帮助和想法,经过调试降低接收电路的灵敏度以后就不会再乱触发中断了。暂时只是看到出了回波波形剩下的电路和程序慢慢来就好弄了。上两个波形图分享给那些可能和我遇到一样的问题的朋友。等做好了如果效果不错的话。我就放出资料给大家。再次感谢。

(原文件名:QQ截图20111208223912.jpg)


(原文件名:QQ截图20111208224009.jpg)

出0入0汤圆

发表于 2011-12-13 20:02:58 | 显示全部楼层
楼主现在做得怎么样了?

出0入0汤圆

发表于 2011-12-14 16:31:12 | 显示全部楼层
我也是发出去没有收到回波。调了好多天了,悲催的

出0入0汤圆

发表于 2011-12-14 21:57:15 | 显示全部楼层
40KHZ的脉冲波可以用单片机pwm模块来提供么?

出0入0汤圆

发表于 2011-12-15 10:28:45 | 显示全部楼层
回复【11楼】newselect 熊宝宝
-----------------------------------------------------------------------

40KHZ的脉冲波可以用单片机pwm模块来提供么?

出0入0汤圆

发表于 2012-2-17 21:01:12 | 显示全部楼层
怎么没有下文了?

出0入0汤圆

发表于 2012-3-2 11:53:49 | 显示全部楼层
回复【27楼】gaoguanyixh
-----------------------------------------------------------------------

我这也没用回波 ,好几天了,一体的探头,把调试注意事项说说吗?

出0入0汤圆

发表于 2012-3-2 21:27:24 | 显示全部楼层
mark

出0入0汤圆

发表于 2012-3-2 21:52:14 | 显示全部楼层
mark

出0入0汤圆

发表于 2012-3-2 22:26:11 | 显示全部楼层
拆个倒车雷达就知道了。

出0入0汤圆

发表于 2012-3-2 22:36:54 | 显示全部楼层
mark

出0入0汤圆

发表于 2012-5-15 14:35:05 | 显示全部楼层
mark,很详细的讨论帖,不知道楼主做咋样了?

出0入0汤圆

发表于 2012-11-21 17:43:31 | 显示全部楼层
楼主不厚道,也米个结论

出0入0汤圆

发表于 2012-11-23 00:22:13 来自手机 | 显示全部楼层
做过倒车雷达的,光是测距的话,是多么的简单。
用16位定时器定时10000us,发完20个波后,每次扫描到输入回波的IO跳变记录当时的定时器值,回波宽度满足一定的值才认为是障碍物,距离=时间值/58。

出0入0汤圆

发表于 2012-12-4 11:46:01 | 显示全部楼层
支持同行

出0入0汤圆

发表于 2016-7-15 15:03:48 | 显示全部楼层
很不错的一体化超声波遇到问题的帖子 ,楼主要回来结贴 总结总结经验 也给我们学习学习

出0入0汤圆

发表于 2018-11-21 13:52:17 | 显示全部楼层
albert_w 发表于 2011-12-8 01:20
实话说楼上的楼上图没看懂。5532每级100db,啥概念,100000倍,你开环么?12M的增益带宽积,顶天也就300倍 ...

根据我最近的调试,这个回复绝对是专业,绝对有指导性!

出0入0汤圆

发表于 2021-10-31 13:22:06 | 显示全部楼层
楼主成功了吗。能分享以下资料吗。我的也是接收不到回波。模电学的太差。研究了四天了。太难了。
回帖提示: 反政府言论将被立即封锁ID 在按“提交”前,请自问一下:我这样表达会给举报吗,会给自己惹麻烦吗? 另外:尽量不要使用Mark、顶等没有意义的回复。不得大量使用大字体和彩色字。
您需要登录后才可以回帖 登录 | 注册

本版积分规则

手机版|Archiver|amobbs.com 阿莫电子论坛 -- 东莞阿莫电子网站 ( 粤ICP备2022115958号, 版权所有:东莞阿莫电子贸易商行 创办于2004年 (公安交互式论坛备案:44190002001997 ) )

GMT+8, 2023-1-31 18:20

© Since 2004 www.amobbs.com, 原www.ourdev.cn, 原www.ouravr.com

快速回复 返回顶部 返回列表