amoBBS 阿莫电子论坛

 找回密码
 注册
搜索
bottom↓
查看: 676|回复: 12

请教一下STC驱动2.4寸彩屏问题,老是白屏

[复制链接]
发表于 2015-1-15 18:41:34 | 显示全部楼层 |阅读模式
从淘宝上买的最小系统和2.4寸触摸彩屏,下载进去的也是给你的例程,引脚接口都改了,上电之后一直白屏,触摸彩屏是LTI9325的主控芯片
,求大神指教啊
 楼主| 发表于 2015-1-15 21:03:07 | 显示全部楼层
我一个个引脚重新用杜邦线一个个接到对应的位置,上电之后屏幕还是白色的,是不是触摸屏是坏的额,刚买的,有没有大神遇到这个问题额?
发表于 2015-1-15 21:08:44 | 显示全部楼层
别断电,将单片机复位一下看看~
发表于 2015-1-15 21:34:25 | 显示全部楼层
有没有背光什么的,是不是可以调调
发表于 2015-1-16 08:09:48 | 显示全部楼层
液晶驱动初始化问题,驱动要修改下
发表于 2015-1-16 18:43:43 | 显示全部楼层
我曾经有一个屏也是这样,是一个开发板自带的,各种测试反正就是白屏,后来用表挨个测pcb走线,发现有个线是断的,接上就好了,不妨测测看。
发表于 2015-1-17 00:25:26 | 显示全部楼层
TFT是3.3v, 你的stc mcu是3.3吗? 如果是5V,就要注意IO的电平了,特别是硬件SPI
 楼主| 发表于 2015-1-23 11:21:04 | 显示全部楼层
fengyuxiaoxiao 发表于 2015-1-15 21:34
有没有背光什么的,是不是可以调调

调了一下背光,果然好了,我以前只知道调12864或者1602的背光,没想到触摸屏还有背光额。谢谢了!
 楼主| 发表于 2015-1-23 11:21:40 | 显示全部楼层
feezai 发表于 2015-1-16 18:43
我曾经有一个屏也是这样,是一个开发板自带的,各种测试反正就是白屏,后来用表挨个测pcb走线,发现有个线 ...

谢谢了,已经解决了额!
 楼主| 发表于 2015-1-23 11:22:32 | 显示全部楼层
feezai 发表于 2015-1-16 18:43
我曾经有一个屏也是这样,是一个开发板自带的,各种测试反正就是白屏,后来用表挨个测pcb走线,发现有个线 ...

恩恩,谢谢提醒额,以后多多交流!
发表于 2015-1-23 12:02:34 | 显示全部楼层
说下原因嘛,以后碰到就可以少走弯路。
发表于 2015-1-23 15:33:32 | 显示全部楼层
接线有没有问题?
 楼主| 发表于 2015-1-25 18:14:14 | 显示全部楼层
孩子莫悲伤 发表于 2015-1-15 21:08
别断电,将单片机复位一下看看~

谢谢,已解决!
友情提示:标题不合格、重复发帖,将会被封锁ID。详情请参考:论坛通告:封锁ID、获得注册邀请码、恢复被封ID、投诉必读
您需要登录后才可以回帖 登录 | 注册

本版积分规则

手机版|Archiver|阿莫电子论坛(原ourAVR/ourDEV) ( 公安备案:44190002001997(交互式论坛) 工信部备案:粤ICP备09047143号 )

GMT+8, 2019-9-16 01:11

阿莫电子论坛, 原"中国电子开发网"

© 2004-2018 www.amobbs.com, 原www.ourdev.cn, 原www.ouravr.com

快速回复 返回顶部 返回列表