amoBBS 阿莫电子论坛

 找回密码
 注册
搜索
bottom↓
查看: 1357|回复: 25

我的STC四轴没飞起来就坏了,是mosfet烧了吗?

[复制链接]
发表于 2015-2-8 22:03:14 | 显示全部楼层 |阅读模式
我的四轴一个下午做好,晚上试飞,油门慢慢加,发现有一个电机力矩根本不够,不能平衡起飞,原因是这个电机我装的时候。把底片电刷那部分弄出来了,可能这样导致不行。我换一个新电机,却发现另外的问题,启动完成后,有2个电机一直在转。请看图,是mosfet烧了吗?还是其他问题?mosfet我没有买多一些备份。

先上个遥控图
IMG_20150208_213746.jpg

拿走手上,油门加到最大,有一个电机烧坏,不转了。这个电机是我安装的时候可能弄的不好。
IMG_20150208_213717.jpg


重新换一个新的,却发现,有2个一直在转,什么回事?
IMG_20150208_215145.jpg
发表于 2015-2-8 22:12:45 | 显示全部楼层
怀疑mosfet,用万用表量一下不就知道了么.
 楼主| 发表于 2015-2-8 22:19:29 | 显示全部楼层
hzpj001 发表于 2015-2-8 22:12
怀疑mosfet,用万用表量一下不就知道了么.

三极管我知道,mosfet怎样量,我还真的没试过,求指教
发表于 2015-2-8 22:53:25 来自手机 | 显示全部楼层
测ds是不是击穿或者烧断。
发表于 2015-2-8 22:57:31 | 显示全部楼层
你们的都到了,我的还在路上
 楼主| 发表于 2015-2-8 23:17:14 | 显示全部楼层
本帖最后由 pazulin 于 2015-2-8 23:20 编辑
fsclub 发表于 2015-2-8 22:53
测ds是不是击穿或者烧断。


我测得4个mosfet 都差不多,ds电阻都很小,只有0.02欧左右,4个都一样,但是gs 就有差别,可以判断,是mosfet坏了
发表于 2015-2-8 23:26:32 | 显示全部楼层
LZ 出现了和我一样的问题,

我怀疑是硬件上保护不够
发表于 2015-2-8 23:28:30 | 显示全部楼层
明天拿工具测试一下,谁能帮我转一个遥控器和飞空原理图PDF

我用的是PADS打不开
发表于 2015-2-8 23:30:01 来自手机 | 显示全部楼层
貌似在哪看过,对于mos这玩意,可能手轻轻一碰,就挂了,最好做好静电防护啊。
发表于 2015-2-9 00:08:38 | 显示全部楼层
我不知道你们那是个什么情况,怎么这么容易烧MOS,不知道是不是MOS的渠道有问题,理论上来讲MOS是最不容易出问题的,不知道是不是回流焊的时候温度过高了还是不注意防静电,我这相同的设计从来没坏过MOS,不过我这是手焊的,如果发现电机有问题,建议把MOS旁边的肖特基去除掉,试试,指不定是那个坏了。
发表于 2015-2-9 00:26:08 | 显示全部楼层
leeseel 发表于 2015-2-8 23:28
明天拿工具测试一下,谁能帮我转一个遥控器和飞空原理图PDF

我用的是PADS打不开 ...

这玩意在程序开源帖里有。
发表于 2015-2-9 07:50:48 来自手机 | 显示全部楼层
makeflyeasy 发表于 2015-2-9 00:26
这玩意在程序开源帖里有。

搞个装配试飞指导手册吧,
发表于 2015-2-9 09:29:11 | 显示全部楼层
pazulin 发表于 2015-2-8 23:17
我测得4个mosfet 都差不多,ds电阻都很小,只有0.02欧左右,4个都一样,但是gs 就有差别,可以判断,是mo ...

DS电阻很小是四个MOSFET都烧了吧?正常不带电测应该是无穷大,至少得有1M欧以上。
 楼主| 发表于 2015-2-9 09:43:04 | 显示全部楼层
fsclub 发表于 2015-2-9 09:29
DS电阻很小是四个MOSFET都烧了吧?正常不带电测应该是无穷大,至少得有1M欧以上。 ...

我真的测得是这样喔,你到货后可以测下
发表于 2015-2-9 09:48:14 | 显示全部楼层
pazulin 发表于 2015-2-9 09:43
我真的测得是这样喔,你到货后可以测下

将GS短接一下再测DS,GS的静电也可以将DS导通的。
发表于 2015-2-9 10:03:53 | 显示全部楼层
那个肖特基二极管的位置放错了。电路设计有问题。需要改原理图,靠mos硬抗电机反电动势可不是好办法,不可靠。mos关闭的时候,电机都没有续流路径,这抖动很大啊,怎么会成功呢?版主应该在投板之前将原理图发上来让大家看看,估计之后烧mos的还有不少。
发表于 2015-2-9 11:28:41 | 显示全部楼层
R88 发表于 2015-2-9 10:03
那个肖特基二极管的位置放错了。电路设计有问题。需要改原理图,靠mos硬抗电机反电动势可不是好办法,不可 ...

应该怎么改进?
发表于 2015-2-9 11:37:38 | 显示全部楼层
laign 发表于 2015-2-9 11:28
应该怎么改进?

焊电机线那块可以焊接
发表于 2015-2-9 12:33:31 | 显示全部楼层
laign 发表于 2015-2-9 11:28
应该怎么改进?

无标题.jpg
发表于 2015-2-9 12:41:31 | 显示全部楼层
话说我的mos管估计也烧了一个!上电有个电机就转,而且转速均匀,和油门无关。昨天太晚了,没来得及测量。我也有个电机把盖子搞掉了。感觉盖子一旦掉了就废了。
发表于 2015-2-9 12:43:56 | 显示全部楼层

这个地方 应该放个高速的二极管都可以的吧?今天回去找找 有不少贴片的1N4148 应该 可以用来吸收电流的。
发表于 2015-2-9 12:47:53 | 显示全部楼层
老魏 发表于 2015-2-9 12:43
这个地方 应该放个高速的二极管都可以的吧?今天回去找找 有不少贴片的1N4148 应该 可以用来吸收电流的。 ...

都可以的,这MOS这么容易烧应该不是设计原因,很多都是一上电就转,第一次上电就转怎么可能是被电机的感应电压击穿的,很明显生产过程中要么是回流焊温度高了,时间长了,要么是生产人员干了些什么事。
发表于 2015-2-9 13:21:26 | 显示全部楼层
makeflyeasy 发表于 2015-2-9 12:47
都可以的,这MOS这么容易烧应该不是设计原因,很多都是一上电就转,第一次上电就转怎么可能是被电机的感 ...

不会是生产人员弄得,昨天晚上回去看了一下原理图,可以确定是那个保护二极管没有放对。
目前看来这个问题应该100%回出现的,电机的感应电压回很高
发表于 2015-2-9 13:26:53 | 显示全部楼层
leeseel 发表于 2015-2-9 13:21
不会是生产人员弄得,昨天晚上回去看了一下原理图,可以确定是那个保护二极管没有放对。
目前看来这个问 ...

那里确实是个设计缺陷,不过我这的MOS从来没有被击穿过,所以一直都没在意到那个问题,昨天和STCunio交流了下,有可能是他采购的电机和我采购的电机不同,我这电机感应电动势要小很多所以没事,解决方法已经在问题汇总帖提出。
发表于 2015-2-9 13:59:03 | 显示全部楼层
你这个就 是坏了。我也是,一个电机停不下来,换了就好了。
发表于 2015-8-11 23:50:26 | 显示全部楼层
想知道楼主把这问题解决了没有
友情提示:标题不合格、重复发帖,将会被封锁ID。详情请参考:论坛通告:封锁ID、获得注册邀请码、恢复被封ID、投诉必读
您需要登录后才可以回帖 登录 | 注册

本版积分规则

手机版|Archiver|阿莫电子论坛(原ourAVR/ourDEV) ( 公安备案:44190002001997(交互式论坛) 工信部备案:粤ICP备09047143号 )

GMT+8, 2019-9-20 23:01

阿莫电子论坛, 原"中国电子开发网"

© 2004-2018 www.amobbs.com, 原www.ourdev.cn, 原www.ouravr.com

快速回复 返回顶部 返回列表