搜索
bottom↓
回复: 8

我是IAR5.3, 安装利尔达的 LSD-FET430UIF 出错了?

[复制链接]
(172462436)

出0入0汤圆

发表于 2015-10-24 18:52:12 | 显示全部楼层 |阅读模式


我是IAR5.3, 安装利尔达的 LSD-FET430UIF 出错了,咋回事,谁知道啊 ?

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
(172462370)

出0入0汤圆

发表于 2015-10-24 18:53:18 | 显示全部楼层
430的仿真器只有LSD-FET430UIF ?太慢了速度,用CCS仿真连接都要10S左右。
(172461204)

出0入0汤圆

 楼主| 发表于 2015-10-24 19:12:44 | 显示全部楼层
enthier 发表于 2015-10-24 18:53
430的仿真器只有LSD-FET430UIF ?太慢了速度,用CCS仿真连接都要10S左右。

我用IAR仿真连接 的
(172461180)

出0入0汤圆

 楼主| 发表于 2015-10-24 19:13:08 | 显示全部楼层
咋回事 版本不对吗
(172460307)

出0入0汤圆

 楼主| 发表于 2015-10-24 19:27:41 | 显示全部楼层
大家 开发msp430都用啥开发环境啊,IAR还是 CCS?
IAR用哪个版本呢? IAR5.4稳定吗 ?
我用IAR5.3的版本,装利尔达仿真器 有问题,好像我以前用  在LSD-FET430UIF的固件上用 过IAR5.4 版本的,再用低版本IAR5.3就不行了,要回头取用IAR5.3 看网上说要降级LSD-FET430UIF的固件;
IAR5.4  IAR5.5现在 好用吗?
如果可以我把IAR5.3升级为高版本,不降级LSD-FET430UIF的固件了,好麻烦
(172457237)

出0入0汤圆

 楼主| 发表于 2015-10-24 20:18:51 | 显示全部楼层
现在 电脑只有 U口,大家 调试MSP430都用啥工具啊  ???
好像 u口只能 通过仿真器连接到 MSP430了吧 ??
(172451824)

出0入0汤圆

发表于 2015-10-24 21:49:04 | 显示全部楼层
TI的MSP430仿真器的固件前后有3个大版本,V1、V2版驱动程序最然不一样,但是可以互相兼容, 而到了V3版固件差别非常大,连USB的VID和PID都变了,相应的驱动也不一样。   其中IAR 5.3及以下的版本只支持V1,V2版,内置驱动也是V1或V2版(驱动程序互相兼容)使用的。

如果你的仿真器之前在别的电脑上使用的时候已经被升级到了V3版本的话, 你在IAR 5.3里面是找不到合适的驱动的。

判断仿真器固件是不是V3版固件,如下:
    在设备管理器的仿真器设备上点击右键,选择“属性”,切换到“详细信息”选项卡,查看“硬件Id”属性:
    如果显示的是:VID_2047&PID_0010,表示固件是V3版本;
    如果显示的是:VID_0451&PID_F430,表示固件是V2版本或者V1版本的固件;

如果显示的确实是V2版本的固件,你就在找找其他原因,
如果显示的是V3版本的固件,你需要在电脑上安装IAR 5.4或以上的版本,才能安装驱动和使用, 如果还是想在IAR 5.3下使用,则需要使用一个单独的“V3固件降级的程序”进行降级,降级后才能被IAR 5.3及以下的软件识别到。

最后提醒一下,V3固件降级到V2固件有风险,有变砖的几率,请谨慎操作。
(43444799)

出0入0汤圆

发表于 2019-11-26 01:06:09 来自手机 | 显示全部楼层
mark  msp fet430uif固件升级
(43444777)

出0入0汤圆

发表于 2019-11-26 01:06:31 来自手机 | 显示全部楼层
mark  msp fet430uif固件升级
回帖提示: 反政府言论将被立即封锁ID 在按“提交”前,请自问一下:我这样表达会给举报吗,会给自己惹麻烦吗? 另外:尽量不要使用Mark、顶等没有意义的回复。不得大量使用大字体和彩色字。
您需要登录后才可以回帖 登录 | 注册

本版积分规则

手机版|Archiver|amobbs.com 阿莫电子论坛 ( 公安交互式论坛备案:44190002001997 粤ICP备09047143号 )

GMT+8, 2021-4-11 21:06

© Since 2004 www.amobbs.com, 原www.ourdev.cn, 原www.ouravr.com

快速回复 返回顶部 返回列表