amobbs.com 阿莫电子论坛

 找回密码
 注册
密码必须由大写、小写、数字组成,三者缺一不可
搜索
bottom↓
回复: 10

W5500插上网线之后网口灯不亮的问题

[复制链接]
(21898335)

出0入0汤圆

发表于 2019-12-1 19:18:11 | 显示全部楼层 |阅读模式
        有一个产品用的是W5500+STM32F0,出货量在2K左右,最近有一个客户有20几台,整个批次都出现过以下问题:
        1、客户刚开始拿到货,20几台全部用笔记本电脑与设备直连,登录WEB,设置参数,就发现有2/3的设备网口灯不亮(WEB也无法登陆)。
        2、让客户不要直连,通过交换机之后再去登录WEB,这样做之后,依然有1/3的设备网口灯不亮。
        3、客户在反复重启,断电,插拔网线之后,所有设备都OK了,网口灯都正常,WEB也都能正常登录。
        4、之后客户把所有设备拿去现场安装,上电之后发现居然有5台的网口灯又不亮了(WEB当然也无法登陆)。

        以上情况,在2K出货的其他设备上,从来没有出现过,仅仅出现在这个20几台的小批量上,且这个批次与其他的批次,除了元器件的购买日期不一样之外,供应商(PCB板与元器件的供应商皆为JLC)、代码程序、测试流程等全部一样。
        应该是可以排除PCB及元器件的批次及质量问题。

        W5500的电路部分与官方推荐的一致,网口用的HR911105A。

        求助万能的论坛,有没有朋友遇到过类似的问题,或可能会是什么样的问题?

       

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
(21897604)

出0入8汤圆

发表于 2019-12-1 19:30:22 来自手机 | 显示全部楼层
查查晶振?复位?通常问题都是这俩引起的
(21896265)

出0入18汤圆

发表于 2019-12-1 19:52:41 | 显示全部楼层
有没有想过是VIA不通?
(21887182)

出0入84汤圆

发表于 2019-12-1 22:24:04 | 显示全部楼层
笔记本设置强制10MBPS半双工连板子看看是否有改善
(21885741)

出0入0汤圆

发表于 2019-12-1 22:48:05 | 显示全部楼层
换个不同品牌网卡的电脑试试,看看是不是挑网卡。之前用的路由器发现过挑网卡
(21855333)

出0入0汤圆

发表于 2019-12-2 07:14:53 来自手机 | 显示全部楼层
会不会mac地址设置的问题?
(21816740)

出0入0汤圆

发表于 2019-12-2 17:58:06 | 显示全部楼层
改变下,晶振的电容值看看
(21763020)

出0入8汤圆

发表于 2019-12-3 08:53:26 | 显示全部楼层
换个交换机 路由器试试  集成的PHY芯片是一个简易的PHY ,很脆弱
(21762805)

出0入0汤圆

发表于 2019-12-3 08:57:01 | 显示全部楼层
楼主看一下晶振,另外可以把你自己的原理图发出来看看,很多客户都说自己按照有官方手册做的图,结果不一样。。。
(21759318)

出0入8汤圆

发表于 2019-12-3 09:55:08 | 显示全部楼层
哈,都是被晶振折腾过的人呀
(21742039)

出0入0汤圆

 楼主| 发表于 2019-12-3 14:43:07 | 显示全部楼层
Himem 发表于 2019-12-1 22:24
笔记本设置强制10MBPS半双工连板子看看是否有改善

这个方法试过了,确实有一些效果,就是原来有几台不亮的,这样设置之后就亮了,但是依然有一些是不亮。看来还是PHY和网卡匹配的问题。
回帖提示: 在按“提交”前,请自问一下:我这样表达会给举报吗,会给自己惹麻烦吗? 另外:尽量不要使用Mark、顶等没有意义的回复。不得大量使用大字体和彩色字。
您需要登录后才可以回帖 登录 | 注册

本版积分规则

手机版|Archiver|amobbs.com 阿莫电子论坛 ( 公安交互式论坛备案:44190002001997 粤ICP备09047143号-1 )

GMT+8, 2020-8-11 06:10

© Since 2004 www.amobbs.com, 原www.ourdev.cn, 原www.ouravr.com

快速回复 返回顶部 返回列表